Skip to main content
← All vulnerabilities
CVE-2022-24775DRUPAL-CORE-2022-006BIT-DRUPAL-2022-24775GHSA-Q7RV-6HP3-VH96

Improper Input Validation in guzzlehttp/psr7

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.4, 2.1.1, 9.2.16, 9.3.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • guzzle psr7

    fixed in 1.8.4; From 2.0.0 · fixed in 2.1.1

  • drupal/corePackagist

    From 8.0.0 · fixed in 9.2.16; From 9.3.0 · fixed in 9.3.9

  • guzzlehttp/psr7Packagist

    fixed in 1.8.4

  • guzzlehttp/psr7Packagist

    From 2.0.0 · fixed in 2.1.1

References 4

GitHub · guzzle/psr7

drupal.org