Skip to main content
← All vulnerabilities
CVE-2022-24722GHSA-CM9W-C4RJ-R2CF

Cross-site Scripting in view_component

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.31.2, 2.49.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • github view_component

    From 2.31.0 · fixed in 2.31.2; From 2.32.0 · fixed in 2.49.1

  • view_componentRubyGems

    From 2.31.0 · fixed in 2.31.2

  • view_componentRubyGems

    From 2.32.0 · fixed in 2.49.1

References 4

GitHub · github/view_component