CVE-2022-24440GHSA-7627-MP87-JF6QSNYK-RUBY-COCOAPODSDOWNLOADER-2414278
Command Injection
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.6.0, 1.6.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a cocoapods-downloader
fixed in 1.6.0; From 1.6.2; fixed in 1.6.3
- cocoapods-downloaderRubyGems
fixed in 1.6.0
- cocoapods-downloaderRubyGems
From 1.6.2 · fixed in 1.6.3