Skip to main content
← All vulnerabilities
CVE-2022-24093GHSA-5XMP-7WG5-X68Q

Adobe Commerce post-auth improper input validation leads to remote code execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.3-p2, 2.3.7-p3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.3.7-p2

  • magento/community-editionPackagist

    2.4.3

  • magento/community-editionPackagist

    2.3.7

  • magento/community-editionPackagist

    From 2.4.3-p1 · fixed in 2.4.3-p2

  • magento/community-editionPackagist

    From 2.3.7-p1 · fixed in 2.3.7-p3

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com