Skip to main content
← All vulnerabilities
CVE-2022-24086GHSA-F8FV-F786-9933BIT-MAGENTO-2022-24086

Adobe Commerce checkout improper input validation leads to remote code execution

Published
Last modified
published
Listed in CISA KEV
Fix
Fixed in 2.3.7-p3, 2.4.3-p2
None on Exploit-DB, Metasploit or GitHub

Summary

Adobe Commerce, an e-commerce platform, is affected by a flaw in how it validates input during checkout. An attacker could exploit this without any user interaction to run arbitrary code on the affected system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Adobe Magento Commerce

    From unspecified · through 2.4.3-p1; From unspecified · through 2.3.7-p2; From unspecified · through None

  • magento/community-editionPackagist

    From 2.3.3-p1 · fixed in 2.3.7-p3

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.3-p2

References 1

helpx.adobe.com