Skip to main content
← All vulnerabilities
CVE-2022-23504GHSA-8W3P-QH3X-6GJRBIT-TYPO3-2022-23504

TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.38, 10.4.33, 11.5.20, 12.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • TYPO3 typo3

    From 9.0.0 · fixed in 9.5.38; From 10.0.0 · fixed in 10.4.33; From 11.0.0 · fixed in 11.5.20; From 12.0.0 · fixed in 12.1.1

  • typo3/cms-corePackagist

    From 9.0.0 · fixed in 9.5.38

  • typo3/cms-corePackagist

    From 10.0.0 · fixed in 10.4.33

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.5.20

  • typo3/cms-corePackagist

    From 12.0.0 · fixed in 12.1.1

  • typo3/cmsPackagist

    From 10.0.0 · fixed in 10.4.33

  • typo3/cmsPackagist

    From 11.0.0 · fixed in 11.5.20

  • typo3/cmsPackagist

    From 12.0.0 · fixed in 12.1.1

References 1

GitHub · TYPO3/typo3