Skip to main content
← All vulnerabilities
CVE-2022-23501GHSA-JFP7-79G7-89RFBIT-TYPO3-2022-23501

TYPO3 vulnerable to Improper Authentication in Frontend Login

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • TYPO3 typo3

    From 8.0.0 · fixed in 8.7.49; From 9.0.0 · fixed in 9.5.38; From 10.0.0 · fixed in 10.4.33; From 11.0.0 · fixed in 11.5.20; From 12.0.0 · fixed in 12.1.1

  • typo3/cms-corePackagist

    fixed in 8.7.49

  • typo3/cms-corePackagist

    From 9.0.0 · fixed in 9.5.38

  • typo3/cms-corePackagist

    From 10.0.0 · fixed in 10.4.33

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.5.20

  • typo3/cms-corePackagist

    From 12.0.0 · fixed in 12.1.1

  • typo3/cmsPackagist

    From 10.0.0 · fixed in 10.4.33

  • typo3/cmsPackagist

    From 11.0.0 · fixed in 11.5.20

  • typo3/cmsPackagist

    From 12.0.0 · fixed in 12.1.1

References 1

GitHub · TYPO3/typo3