CVE-2022-22978GHSA-HH32-7344-CG2F
In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigure
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.5.7, 5.6.4, 5.4.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 7 proofs of concept on GitHub
Summary
In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a Spring Security
Version range not reported
- org.springframework.security:spring-security-coreMaven
From 5.5.0 · fixed in 5.5.7
- org.springframework.security:spring-security-coreMaven
From 5.6.0 · fixed in 5.6.4
- org.springframework.security:spring-security-coreMaven
fixed in 5.4.11
- org.springframework.security:spring-security-webMaven
From 5.5.0 · fixed in 5.5.7
- org.springframework.security:spring-security-webMaven
From 5.6.0 · fixed in 5.6.4
- org.springframework.security:spring-security-webMaven
fixed in 5.4.11