Skip to main content
← All vulnerabilities
CVE-2022-22971GHSA-RQPH-VQWM-22VC

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vu

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.3.20, 5.2.22.RELEASE
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a Spring Framework

    Spring Framework versions 5.3.x prior to 5.3.20, 5.2.x prior to 5.2.22 and all old and unsupported versions

  • org.springframework:spring-messagingMaven

    From 5.3.0 · fixed in 5.3.20

  • org.springframework:spring-messagingMaven

    fixed in 5.2.22.RELEASE

References 3

tanzu.vmware.com

oracle.com

security.netapp.com