CVE-2022-22969GHSA-C2CP-3XJ9-97W9
<Issue Description> Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Servic
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.5.2.RELEASE, 2.4.2.RELEASE
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
<Issue Description> Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Spring Security OAuth
Version range not reported
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.5.0.RELEASE · fixed in 2.5.2.RELEASE
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.4.0.RELEASE · fixed in 2.4.2.RELEASE