Skip to main content
← All vulnerabilities
CVE-2022-22950GHSA-558X-2XJG-6232

n Spring Framework versions 5.3.0 - 5.3.16 and older unsupported versions, it is possible for a user to provide a specially crafted SpEL exp

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.3.17, 5.2.20.RELEASE
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

n Spring Framework versions 5.3.0 - 5.3.16 and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a Spring Framework

    Spring Framework versions 5.3.X prior to 5.3.17+ and all old and unsupported versions

  • org.springframework:spring-expressionMaven

    From 5.3.0 · fixed in 5.3.17

  • org.springframework:spring-expressionMaven

    fixed in 5.2.20.RELEASE

References 1

tanzu.vmware.com